neliasso [Thu, 17 May 2018 12:08:32 +0200] rev 50165
8203215: IdealLoopTree::split_outer_loop leaves phi-nodes with only one input
Summary: Make sure the phis are transformed
Reviewed-by: roland, kvn, rbackman
eosterlund [Thu, 17 May 2018 11:56:21 +0200] rev 50164
8202479: Add missing try_resolve_jobject_in_native calls
Reviewed-by: coleenp, pliden
mgronlun [Thu, 17 May 2018 14:31:31 +0200] rev 50163
8203346: JFR: Inconsistent signature of jfr_add_string_constant
Reviewed-by: shade
mdoerr [Thu, 17 May 2018 14:19:54 +0200] rev 50162
8202713: Create a MacroAssembler::access_load/store_at wrapper for S390 and PPC
Reviewed-by: eosterlund, goetz
gromero [Wed, 16 May 2018 11:11:03 -0400] rev 50161
8203305: PPC64: Improve TM detection for enabling RTM on Linux / POWER9
Reviewed-by: mdoerr
mdoerr [Thu, 17 May 2018 14:16:49 +0200] rev 50160
8203288: PPC64 and s390 fail to build after JDK-8199712 (Flight Recorder)
Reviewed-by: shade
asaha [Thu, 17 May 2018 11:03:19 +0000] rev 50159
Added tag jdk-11+14 for changeset 3595bd343b65
rehn [Thu, 17 May 2018 10:32:26 +0200] rev 50158
8195098: Low latency hashtable for read-mostly scenarios
Summary: This implement a concurrent hashtable using chaining and the GlobalCounter for ABA problems.
Reviewed-by: acorn, coleenp, dcubed, eosterlund, gziemski, mlarsson
pliden [Thu, 17 May 2018 09:35:38 +0200] rev 50157
8202978: Incorrect tmp register passed to MacroAssembler::load_mirror()
Reviewed-by: kvn, coleenp
iignatyev [Thu, 17 May 2018 00:23:28 -0700] rev 50156
8199384: [TESTBUG] Open source VM testbase MLVM tests
Reviewed-by: erikj, mseledtsov, vlivanov
mseledtsov [Wed, 16 May 2018 16:43:57 -0700] rev 50155
Merge
mseledtsov [Wed, 16 May 2018 16:43:11 -0700] rev 50154
8199252: [TESTBUG] Open source VM testbase system dictionary tests
Summary: Opensourced the tests
Reviewed-by: iignatyev, gziemski
iveresov [Wed, 16 May 2018 15:19:28 -0700] rev 50153
8201447: C1 does backedge profiling incorrectly
Summary: Increment backedge counter only for backward arms of conditional branches.
Reviewed-by: never, kvn
iklam [Tue, 15 May 2018 14:49:10 -0700] rev 50152
8189140: SystemDictionaryShared::initialize() should be renamed to be more meaningful
Summary: Removed this function, added JavaCalls::construct_new_instance and moved SharedDictionary_lock
Reviewed-by: jiangli, ccheung, dholmes, coleenp
prr [Wed, 16 May 2018 10:27:25 -0700] rev 50151
Merge
prr [Wed, 16 May 2018 09:45:40 -0700] rev 50150
Merge