src/CMakeLists.txt
branchv_0
changeset 8 ff115d10f901
child 9 30528cbe8838
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/src/CMakeLists.txt	Sun Dec 09 19:40:17 2018 +0100
@@ -0,0 +1,24 @@
+# Relational pipes
+# Copyright © 2018 František Kučera (Frantovo.cz, GlobalCode.info)
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+set(LIBRARY_FILE "relpipe-lib-cli")
+
+# Library output:
+add_library(
+	${LIBRARY_FILE} SHARED
+	relpipe-lib-cli.cpp
+)
+