alanb [Thu, 01 Jul 2010 16:28:08 +0100] rev 5995
6947216: Even more Dual-pivot quicksort improvements
Reviewed-by: jjb
Contributed-by: vladimir.yaroslavskiy@sun.com
martin [Wed, 30 Jun 2010 16:11:32 -0700] rev 5994
6940258: (bf) Use intrinsified reverseBytes operation; elide no-op constructs
Reviewed-by: alanb, sherman
Contributed-by: Ulf Zibis <ulf.zibis@gmx.de>
martin [Wed, 30 Jun 2010 16:11:32 -0700] rev 5993
6935172: Optimize bit-twiddling in Bits.java
Summary: Transformations to reduce size of bytecode
Reviewed-by: sherman
Contributed-by: Based on an idea by Ulf Zibis <ulf.zibis@gmx.de>
martin [Wed, 30 Jun 2010 16:11:32 -0700] rev 5992
6934271: Better handling of longer utf-8 sequences
Summary: Various cleanups, including clever bit-twiddling
Reviewed-by: sherman
martin [Wed, 30 Jun 2010 16:11:32 -0700] rev 5991
6933322: Add methods highSurrogate(), lowSurrogate() to class Character
Summary: Add public variants of methods Surrogate.high, Surrogate.low
Reviewed-by: okutsu, sherman
Contributed-by: Ulf Zibis <ulf.zibis@gmx.de>
martin [Wed, 30 Jun 2010 16:11:32 -0700] rev 5990
6934270: Remove javac warnings from Character.java
Summary: Use generics and conform to coding style
Reviewed-by: sherman
Contributed-by: Ulf Zibis <ulf.zibis@gmx.de>
martin [Wed, 30 Jun 2010 16:11:32 -0700] rev 5989
6963749: Minor improvements to Character.UnicodeBlock
Summary: Fix surrogate area docs; make source more readable
Reviewed-by: okutsu, sherman
Contributed-by: Ulf Zibis <ulf.zibis@gmx.de>
martin [Wed, 30 Jun 2010 16:11:32 -0700] rev 5988
6940381: Wording improvements for String.indexOf, String.lastIndexOf
Summary: Make wording of javadoc clearer and more consistent
Reviewed-by: sherman
martin [Wed, 30 Jun 2010 16:11:32 -0700] rev 5987
6937112: String.lastIndexOf confused by unpaired trailing surrogate
Summary: Rewrite lastIndexOf for performance and correctness
Reviewed-by: sherman
Contributed-by: Reviewed by Ulf Zibis <ulf.zibis@gmx.de>
martin [Wed, 30 Jun 2010 16:11:32 -0700] rev 5986
6934265: Add public method Character.isBmpCodePoint
Summary: Move isBmpCodePoint from sun.nio.cs.Surrogate to Character
Reviewed-by: sherman
Contributed-by: Ulf Zibis <ulf.zibis@gmx.de>