common/autoconf/configure.ac
changeset 42532 4780f4130eb0
parent 42296 671fe155ec14
child 46196 822ca950ddaa
--- a/common/autoconf/configure.ac	Sun Dec 11 12:09:13 2016 -0800
+++ b/common/autoconf/configure.ac	Sun Dec 11 18:50:18 2016 -0800
@@ -205,7 +205,7 @@
 
 # Need toolchain to setup dtrace
 HOTSPOT_SETUP_DTRACE
-HOTSPOT_SETUP_JVM_FEATURES
+HOTSPOT_ENABLE_DISABLE_AOT
 HOTSPOT_ENABLE_DISABLE_GTEST
 
 ###############################################################################
@@ -220,6 +220,10 @@
 LIB_DETERMINE_DEPENDENCIES
 LIB_SETUP_LIBRARIES
 
+# Hotspot setup depends on lib checks (AOT needs libelf).
+
+HOTSPOT_SETUP_JVM_FEATURES
+
 ###############################################################################
 #
 # We need to do some final tweaking, when everything else is done.