make/autoconf/configure.ac
branchihse-cflags-rewrite-branch
changeset 56177 2fbe3b84ee3d
parent 56176 b3e3a12dcb33
child 56194 8b7430e0a67a
--- a/make/autoconf/configure.ac	Mon Feb 26 14:10:16 2018 +0100
+++ b/make/autoconf/configure.ac	Mon Feb 26 14:23:19 2018 +0100
@@ -163,11 +163,9 @@
 # First determine the toolchain type (compiler family)
 TOOLCHAIN_DETERMINE_TOOLCHAIN_TYPE
 
-# User supplied flags should be used when configure detects compilers
-FLAGS_SETUP_USER_SUPPLIED_FLAGS
-# The sysroot cflags are needed for configure to be able to run the compilers
-FLAGS_SETUP_SYSROOT_FLAGS
-FLAGS_SETUP_GLOBAL_FLAGS
+# The global flags are needed for configure to be able to run the compilers
+# correctly.
+FLAGS_PRE_TOOLCHAIN
 
 # Then detect the actual binaries needed
 TOOLCHAIN_PRE_DETECTION
@@ -185,18 +183,15 @@
 # Setup Jib dependency tool
 TOOLCHAIN_SETUP_JIB
 
-FLAGS_SETUP_POST_TOOLCHAIN
+# After toolchain setup, we need to process some flags to be able to continue.
+FLAGS_POST_TOOLCHAIN
 
 # Now we can test some aspects on the target using configure macros.
 PLATFORM_SETUP_OPENJDK_TARGET_BITS
 PLATFORM_SETUP_OPENJDK_TARGET_ENDIANNESS
 
 # Configure flags for the tools
-FLAGS_SETUP_FLAGS_PER_TYPE
-FLAGS_SETUP_COMPILER_FLAGS_FOR_OPTIMIZATION
-FLAGS_SETUP_CFLAGS
-FLAGS_SETUP_LDFLAGS
-FLAGS_SETUP_MISC_FLAGS
+FLAGS_SETUP_FLAGS
 
 #FIXME: REMOVE
 FLAGS_SORT_FLAGS(JVM_CFLAGS)