make/data/jdwp/jdwp.spec
changeset 48623 b1006bbb925a
parent 47216 71c04702a3d5
child 50530 7e3aa681a484
equal deleted inserted replaced
48622:a92a5a71364a 48623:b1006bbb925a
     1 /*
     1 /*
     2  * Copyright (c) 1998, 2017, Oracle and/or its affiliates. All rights reserved.
     2  * Copyright (c) 1998, 2018, Oracle and/or its affiliates. All rights reserved.
     3  * DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
     3  * DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
     4  *
     4  *
     5  * This code is free software; you can redistribute it and/or modify it
     5  * This code is free software; you can redistribute it and/or modify it
     6  * under the terms of the GNU General Public License version 2 only, as
     6  * under the terms of the GNU General Public License version 2 only, as
     7  * published by the Free Software Foundation.  Oracle designates this
     7  * published by the Free Software Foundation.  Oracle designates this
   867         "generic signature if there is one.  "
   867         "generic signature if there is one.  "
   868         "Generic signatures are described in the signature attribute "
   868         "Generic signatures are described in the signature attribute "
   869         "section in "
   869         "section in "
   870         "<cite>The Java&trade; Virtual Machine Specification</cite>. "
   870         "<cite>The Java&trade; Virtual Machine Specification</cite>. "
   871         "Since JDWP version 1.5."
   871         "Since JDWP version 1.5."
   872         "<p>
       
   873         (Out
   872         (Out
   874             (referenceType refType "The reference type ID.")
   873             (referenceType refType "The reference type ID.")
   875         )
   874         )
   876         (Reply
   875         (Reply
   877             (string signature
   876             (string signature
  2721         "composite event is always used "
  2720         "composite event is always used "
  2722         "to deliver events, even if there is only one event to report. "
  2721         "to deliver events, even if there is only one event to report. "
  2723         "<P>"
  2722         "<P>"
  2724         "The events that are grouped in a composite event are restricted in the "
  2723         "The events that are grouped in a composite event are restricted in the "
  2725         "following ways: "
  2724         "following ways: "
  2726         "<P>"
       
  2727         "<UL>"
  2725         "<UL>"
  2728         "<LI>Only with other thread start events for the same thread:"
  2726         "<LI>Only with other thread start events for the same thread:"
  2729         "    <UL>"
  2727         "    <UL>"
  2730         "    <LI>Thread Start Event"
  2728         "    <LI>Thread Start Event"
  2731         "    </UL>"
  2729         "    </UL>"